Bug #1013

xymon scripts that query /dev/disk/by-id look at the wrong disks when a raid disk is present

Added by thekingofspain about 1 year ago. Updated about 1 year ago.

Status:Closed Start date:05/06/2017
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:- Spent time: -
Target version:-

Description

the xymon-smart.sh and xymon-hddtmp.sh scripts have the following like the query disks:

ls /dev/disk/by-id/* | grep ve '-part' -ve '/wwn' |

the line should be the following to remove the mdadm raid devices:

ls /dev/disk/by-id/* | grep ve '-part' -ve '/wwn' ve '/md' |

In addition an the disks being used in mdadm raid are not going to to be listed in the subsequent mount query thus
an addition check should be added to agaist the /proc/mdstat for the mounted raid disk

#check if device is directly mounted
if ! mount | grep -q /dev/$DISKDEV
then # check if device is mounted by mdadm
if ! cat /proc/mdstat | grep -q $DISKDEV
then
continue
fi
fi

Related issues

related to LinHES - Feature #1012: xymon scripts that query /dev/disk/by-id look at the wron... Closed 05/06/2017

History

Updated by brfransen about 1 year ago

  • Status changed from New to Closed

Duplicate of #1012

Also available in: Atom PDF