Bug #1031

MCE remote no longer works after update to 8.5.2

Added by cluehawk 11 days ago. Updated 5 days ago.

Status:Feedback Start date:01/05/2019
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Other Spent time: -
Target version:-

Description

After updating to LINHES 8.5.2 or installing directly from 8.5.2 media, the MCE IR remote no longer functions.
It worked in the previous version.

History

Updated by brfransen 10 days ago

  • Status changed from New to Feedback
  • Target version deleted (8.5)
  • Priority changed from High to Normal

What is the device id shown in lsusb of your MCE remote. Which remote profile are you using in LinHES Settings > Remotes? Is that the same profile you used in the previous version of LH? What version of LH did it work in before?

Updated by cluehawk 10 days ago

Thanks for looking into this issue.
Device id:045e:006d microsoft corp. eHome remote keyboard keys

This device worked on Linhes for the past 5 years.
I confirmed it worked on the 8.4.3 install media.
Remote is set to MCE
the receiver is set to mce.
This is the profile I've always used.
LinHes has always bested all other mythtv distributions when it comes to remotes.
I support three different installations in three different homes.

Updated by brfransen 9 days ago

That device should work. R8.5.2 update does have a newer version of lirc.

Do you have a custom remote profile in home that is also called MCE?
Does irw show anything when buttons are pressed?
Is lirc running? ps aux | grep lirc

Updated by cluehawk 8 days ago

No custom profile in home.
Lirc is running with the MCE profile:
884 ? S 0:00 /usr/bin/lircd -r -n -d /dev/remotes/mce_lirc --output /var/run/lirc/lircd
889 ? S 0:00 /usr/bin/irexec /etc/lircrc

but IRW shows no input when buttons are pressed. I can confirm that the remote and receiver are working in an older version.

I messed with it a bit and after unplugging the receiver and re-inserting it the arrows registered on IRW but nothing else.
after re-configuring LIRC through LinHes, none of the buttons are working.

Thanks for your help!!

Also available in: Atom PDF