Feature #908

R8 2/11/2013 Firefly Remote Missing Buttons

Added by RacerX over 4 years ago. Updated about 4 years ago.

Status:Closed Start date:03/02/2013
Priority:Normal Due date:
Assignee:jams % Done:

0%

Category:- Spent time: 2.00 hours
Target version:8.0

Description

I just upgraded my stand alone frontend to R8... nice work so far!! However, I did notice that many of the Firefly's buttons aren't working, only a few of them work so here is my XML config from XBMC. This should allow more for tighter control with the remote

<remote device="Snapstream_Firefly">
<pause>PAUSE</pause>
<stop>STOP</stop>
<forward>FWD</forward>
<reverse>REW</reverse>
<left>LEFT</left>
<right>RIGHT</right>
<up>UP</up>
<down>DOWN</down>
<select>OK</select>
<pageplus>CH+</pageplus>
<pageminus>CH-</pageminus>
<back>EXIT</back>
<menu>MENU</menu>
<title>PLAY</title>
<info>INFO</info>
<skipplus>NEXT</skipplus>
<skipminus>PREV</skipminus>
<display>MAXI</display>
<start>FIREFLY</start>
<record>REC</record>
<volumeplus>VOL+</volumeplus>
<volumeminus>VOL-</volumeminus>
<mute>MUTE</mute>
<power>CLOSE</power>
<one>1</one>
<two>2</two>
<three>3</three>
<four>4</four>
<five>5</five>
<six>6</six>
<seven>7</seven>
<eight>8</eight>
<nine>9</nine>
<zero>0</zero>
</remote>

lircrc-snapstrm.txt - Snapstream Firefly lircrc txt (3.3 kB) RacerX, 06/04/2013 09:33 am

Associated revisions

Revision cc663d6f
Added by jams over 4 years ago

xbmc: Fix xml to call the shell script for xbmc instead of xbmc directly
refs #908
closes #908

Revision a1b54c58
Added by jams over 4 years ago

system-templates: Fixed firefly lirc mapping. config files provided by RacerX
Also add xbmc.xml for xbmc lirc mapping.

refs #908
closes #908

History

Updated by RacerX over 4 years ago

To clarify here's a little more information. In the MythVantage Snapstream_Firefly Conf there are some issues.

These buttons don't work
Vol+
Vol-
CH+
CH-
INFO

Pushing the Stop button performs the function of the INFO button.

Updated by RacerX over 4 years ago

RacerX wrote:

To clarify here's a little more information. In the MythVantage Snapstream_Firefly Conf there are some issues.

These buttons don't work
Vol+
Vol-
CH+
CH-
INFO

Pushing the Stop button performs the function of the INFO button.

The mute button shows on the screen as "mute on" but it doesn't mute the sound

Updated by RacerX over 4 years ago

When watching live TV the record button doesn't work to record the show you are watching

RacerX wrote:

RacerX wrote:

To clarify here's a little more information. In the MythVantage Snapstream_Firefly Conf there are some issues.

These buttons don't work
Vol+
Vol-
CH+
CH-
INFO

Pushing the Stop button performs the function of the INFO button.

The mute button shows on the screen as "mute on" but it doesn't mute the sound

Updated by jams over 4 years ago

Do you have working lirc files that could replace the ones shipped?

Updated by RacerX over 4 years ago

jams wrote:

Do you have working lirc files that could replace the ones shipped?

Suspected the lircd.snapstrm.conf but it matches what's on the web historically. Some of the keys do the wrong fuction others do nothing.

Updated by jams over 4 years ago

RacerX wrote:

jams wrote:

Do you have working lirc files that could replace the ones shipped?

Suspected the lircd.snapstrm.conf but it matches what's on the web historically. Some of the keys do the wrong fuction others do nothing.

all teh buttons on that remote function. The problem is lircrc appears to be a cut/paste from other remotes. Those buttons have been "not working" for a very long time.

Updated by RacerX over 4 years ago

jams wrote:

RacerX wrote:

jams wrote:

Do you have working lirc files that could replace the ones shipped?

Suspected the lircd.snapstrm.conf but it matches what's on the web historically. Some of the keys do the wrong fuction others do nothing.

all teh buttons on that remote function. The problem is lircrc appears to be a cut/paste from other remotes. Those buttons have been "not working" for a very long time.

Reworked lircrc-snapstream.txt - fixed mislabeled buttons, removed xine and mplayer configs, setup jump points

Updated by jams over 4 years ago

Reworked lircrc-snapstream.txt - fixed mislabeled buttons, removed xine and mplayer configs, setup jump points

Funny I just finished doing almost the same thing. If your certain this layout is complete, I will use it instead

Updated by RacerX over 4 years ago

jams wrote:

Reworked lircrc-snapstream.txt - fixed mislabeled buttons, removed xine and mplayer configs, setup jump points

Funny I just finished doing almost the same thing. If your certain this layout is complete, I will use it instead

So far so good I tested on R7.5. Additionally, would like to add the Help button to show ALT-H but I'm not quite how to create a button?

Updated by jams over 4 years ago

Untested but this should do it.

begin
prog = irxevent
button = HELP
repeat = 3
config = Key ALT-H
end

Updated by jams over 4 years ago

  • Assignee set to jams
  • Status changed from New to Closed
  • Target version set to 8.1

packaged files provided by RacerX.
Added in config so that the help button on the remote issues an alt+h

Updated by brfransen about 4 years ago

  • Target version changed from 8.1 to 8.0

Also available in: Atom PDF