Bug #998

Kodi 15.1 regression uPnP access of HDHomeRun tuner no longer works

Added by nullsmack almost 4 years ago. Updated almost 4 years ago.

Status:Closed Start date:09/16/2015
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:Packages: Extra Spent time: -
Target version:-

Description

Please see this ticket on the Kodi tracker:
http://trac.kodi.tv/ticket/14204

This is an issue that originally showed up in v12.1 and was fixed, but regressed for the v15 branch. There is now a fix for it in their git repository. The text from the above issue follows:

A change in 12.1 systematically adds a RANGE tag to the video HTTP-GET request which breaks operation with non-seekable (live TV) DLNA DMS devices.

DLNA requires that a DMP (XMBC) not send a RANGE request to the DMS if the protocol info does not indicate the stream is seekable. The seekable-ness of the stream is detected by the presence or absence of DLNA.ORG_OP=xx. (If the stream is seekable the OP value will be non-zero. If not seekable the OP tag is absent).

Admittedly this is a brain-dead requirement because HTTP RFCs allow a server that does not support RANGE to ignore it... the problem is that DLNA certification process requires that a DLNA DMS reject any HTTP-GET request containing a RANGE tag when non-seekable content is selected (ie live TV).

So net result - 12.0 works well with the HDHomeRun, 12.1 does not play video, and the HDHomeRun must reject the 12.1 HTTP-GET request in order to maintain DLNA certification.

The fix needed is to detect the DLNA.ORG_OP=xx tag in the CDS protocol info... if OP value is present and non-zero then send a RANGE tag in the HTTP-GET. If the OP value is not present or 00 then do not send RANGE tag in the HTTP-GET and don't allow seeking.

Nick - Silicondust (makers of the HDHomeRun and DLNA member)

(scroll to the bottom of the ticket to see the recent activity)

Associated revisions

Revision ceb6d359
Added by brfransen almost 4 years ago

kodi: fix hdhr uPnP issue. closes #998

History

Updated by brfransen almost 4 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

Also available in: Atom PDF